New worldbeyblade.org — bug and issue reporting

Try reducing the number of posts shown per page in your settings. Not sure if this will help but curious. The default was actually increased recently. 

There is a lot of work to do in terms of optimizing the site for speed and performance, but we will keep at it.
(Dec. 17, 2016  4:42 PM)Bey Brad Wrote: Try reducing the number of posts shown per page in your settings. Not sure if this will help but curious. The default was actually increased recently. 

There is a lot of work to do in terms of optimizing the site for speed and performance, but we will keep at it.

Yeah I wanted to say that was the problem too, the default amount of posts per page is ridiculous. I didn't even know that was a setting lol.

EDIT: Well okay it seems to work right now, but I assume it's because this page has less posts. I'll have to see if it works on the long run, but thanks for the suggestion Brad. And yes, I did use my phone to post this edit for my comment, and it worked okay.
Searching within a forum now works. I also reduced the default number of posts back to 25. I'll continue optimizing the performance over coming weeks and months.

I am pretty sick right now but I hope to get through quite a bit more this weekend if I can summon the energy.
I was saving a thread for the Burst customization topic and was pretty disappointed to see my thread not being saved into 'My Drafts'...

*sigh* Time to rewrite everything.
(Dec. 17, 2016  10:43 PM)Brisk AquarioHD Wrote: I was saving a thread for the Burst customization topic and was pretty disappointed to see my thread not being saved into 'My Drafts'...

*sigh* Time to rewrite everything.

Literally just had the same issue lol. All my other drafts were gone too, rip Tongue_out
Sorry Unhappy The drafts issue was already noted but this one is truly strange ... I'll remove the controls for now.
(Dec. 17, 2016  11:23 PM)Bey Brad Wrote: Sorry Unhappy The drafts issue was already noted but this one is truly strange ... I'll remove the controls for now.
No worries! I already rewrote it. Joyful_3
Take your time.
Adding spoilers isn't working in this thread: https://worldbeyblade.org/Thread-Team-St...s-Miami-FL

The information that's supposed to be in spoilers isn't hidden but it looks perfectly fine once I click on spoiler?
(I also noticed we don't have a spoiler button as of now?)
(Dec. 18, 2016  9:00 PM)Brisk AquarioHD Wrote: Adding spoilers isn't working in this thread: https://worldbeyblade.org/Thread-Team-St...s-Miami-FL

The information that's supposed to be in spoilers isn't hidden but it looks perfectly fine once I click on spoiler?
(I also noticed we don't have a spoiler button as of now?)

Because of the software upgrade, we had to change the editor. But the editor software was very buggy, so we switched to a different one at the last moment. We'll customize the editor controls much more in the near future.

I am not sure what your comment about spoilers means, sorry. I see there is information in spoilers in the thread. When I click the spoiler, it expands to show the hidden information. Is it displaying the wrong info?
Fixed show/hide password toggle on registration page. That's all for today, but feeling a lot better. Lots more soon Smile
(Dec. 19, 2016  12:02 AM)Bey Brad Wrote: Because of the software upgrade, we had to change the editor. But the editor software was very buggy, so we switched to a different one at the last moment. We'll customize the editor controls much more in the near future.

I am not sure what your comment about spoilers means, sorry. I see there is information in spoilers in the thread. When I click the spoiler, it expands to show the hidden information. Is it displaying the wrong info?
Some of the information is showing out of the spoilers as shown below:

[Image: Y0ou1mF.jpg]

However, the information is viewed fine once I clicked on the spoiler button.

(P.S, my tournament thread is also gone along with the Event Proposal? I would like to edit it)

Take your time! I'm glad you're feeling better. :) We appreciate the hard work you're putting into the WBO.
Someone was playing around with the permissions for that forum Brisk, sorry! Wink It should be OK now.

Will look more into the spoiler thing later, but try using the code view and make sure all your tags are opened and closed properly. It seems like you have a lot of custom text formatting going on.
(Dec. 19, 2016  4:52 PM)Bey Brad Wrote: Someone was playing around with the permissions for that forum Brisk, sorry! Wink It should be OK now.

Will look more into the spoiler thing later, but try using the code view and make sure all your tags are opened and closed properly. It seems like you have a lot of custom text formatting going on.
No worries!

Weirdly, it's formatted right but it's okay! Thanks for your help. Smile
OK, I'll check it out more later.
My Safari still crashes whenever I open any thread. I use iPod touch 4 the gen.
ipod touch 4 gen use iOS 6.idk.1. a lot of sites are going to crash because of this. i have one too. thats why i use a computer. its not a WBO problem, its just because of old iOS Ninja Blader
Well, while iOS 6 is old, I don't know that the browser crashing is normal behaviour. I'll try to get access to an old iOS device so I can do some trouble-shooting.

When you say any thread, do you really mean any thread? Do threads with only a few posts and images still crash your browser?
no i have this device and literally every new and updated website is not compatible with it. the old WBO had no problems with it however. thats why i think it is normal. WBO doesn't even load completely on mine
I have an old iPod running iOS 6.1.16 and it is true that any topic with a few posts seems to make Safari close, and then when you open it again, it went back to the forum before you clicked on the thread link. However, I do think that it happens with any major site hah.

For example, the thread on Usergroup Changes worked fine, as it only has one post.
My badge under my profile pic went from Organizer to Passport after I received a new passport? Shouldn't it have stayed as Organizer?
Can I request a slight functional change? Instead of clicking a topic title and going to the first page, can we please go to the last read page? The current system makes huge threads annoying on PC but it's far worse on mobile as the one way to advance is a page at a time.
(Dec. 27, 2016  5:18 PM)Ultra Wrote: My badge under my profile pic went from Organizer to Passport after I received a new passport? Shouldn't it have stayed as Organizer?

That's an existing bug from the old design. I've swapped your Passport and Organiser roles now, so Organiser is your display role.

(Dec. 27, 2016  5:29 PM)Dracomageat Wrote: Can I request a slight functional change? Instead of clicking a topic title and going to the first page, can we please go to the last read page? The current system makes huge threads annoying on PC but it's far worse on mobile as the one way to advance is a page at a time.

Learned this from Brad recently; clicking the orange arrow button next to the thread title will take you to the last read page. We could probably make this clearer somewhere, as I wasn't aware until I was told either :P

For reference;
  • Thread Title - Takes you to the opening post on page 1.
  • Orange Arrow - Takes you to the first unread post in the thread.
  • User or Recent Post Time - Takes you to the newest post in the thread, regardless of which you've read.
Still slightly cumbersome but thankyou for the solution. I will say, though, that clicking users to reach a page besides their profiles seems a tad unintuitive.
I am not sure why clicking the arrow to go to the latest unread post is confusing, since this is exactly how it worked before. Only now the arrow is orange instead of green.

I actually agree that clicking a topic title to go to the last unread post would be functionally better, but I worried that this would be extremely disorienting since it's never worked that way and it's pretty non-standard. I might start some sort of beta test group to test things like this sometime next year.

Quote:Still slightly cumbersome but thankyou for the solution. I will say, though, that clicking users to reach a page besides their profiles seems a tad unintuitive.

Clicking a name does bring you to someone's profile. Maybe because the profile is than different before, you didn't notice? Or perhaps there's a broken link somewhere?

BTW, big thank you to everyone who encouraged me to take the time to rest. I'm feeling tons better and looking forward to digging into this since I'm off until the new year. :)