World Beyblade Organization by Fighting Spirits Inc.

Full Version: Shooter Issue..Need Help!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I dont have the MFB string shooter so I use the standard one. The problem is, when I shoot straight or shoot at all, it sounds like the gears are stripping and it completely messes up the shot and gives the blade a very low spin rate. I have opened it, and nothing is broken or chipped. What can I do?
:s Do you twist the MFB on before you launch it Speechless
No not at all. It makes that sound as if I do though.
Maybe you aren't inserting ther blade correctly?
make sure your winder is fully straightened. It sounds like a case of bad winder.

Also make sure any of the teeth on your winder is not worn down.
My winder is practically brand new and I am looking now and my gears aren't worn at all. I dont know whats going on at all.
(May. 30, 2009  11:40 PM)Ozzy Wrote: [ -> ]My winder is practically brand new and I am looking now and my gears aren't worn at all. I dont know whats going on at all.

Look at how you insert the blade, one of your wings is on top, and not fully in the hole.
It's not that either, as this was my first idea of what the issue was until I checked.
I wish I could help but I dont have a regular launcher..or a string shooter.But if this works the same as HMS then maybe one of your wings are loose
(May. 30, 2009  11:46 PM)Ozzy Wrote: [ -> ]It's not that either, as this was my first idea of what the issue was until I checked.

Turn it upside down.
Put the blade on.
Once securely on pull it up, is the wing loose?
Turn the blade both diretions, waht happens?
Try shooting and give us a 10 excat description.
Are you sure the ripcord is straight enough or that you are pulling straight out? You should practice shooting without a blade on.
Are you positive you're not turning the ripcord to far to the side when pulling?
I have done all of these things and all tests work fine. The launch is horrible. I would be better off spinning it with my hand. Thats how bad it is.
(May. 31, 2009  12:07 AM)Ozzy Wrote: [ -> ]I have done all of these things and all tests work fine. The launch is horrible. I would be better off spinning it with my hand. Thats how bad it is.

Are you shooting too slow?
If you'd seriously be better off spinning it with your hands, it's busted. Get a new one.
(May. 31, 2009  12:15 AM)Bey Brad Wrote: [ -> ]If you'd seriously be better off spinning it with your hands, it's busted. Get a new one.

He did say he opened it. It was slow, and opening it just deteriates the preformance more. He may have concraticted himself, when he may have just been shooting faulty.
Thanks for everything you guys. I happened to fix it. It seems that the design was a bit off I guess due to a manufacturing error with the gears. Luckily I had a spare gear so I made it work.
(May. 31, 2009  12:48 AM)Ozzy Wrote: [ -> ]Thanks for everything you guys. I happened to fix it. It seems that the design was a bit off I guess due to a manufacturing error with the gears. Luckily I had a spare gear so I made it work.

Awsome man.
i have the exact same problem with my 2 launchers Gasp
but my beylaunchers works fine Smile